Supported Computers

This page lists current supported models of UCA-owned computers.

All devices come with a warranty for hardware failure that’s good for three years after the initial purchase. After this date, IT will attempt to fix or replace faulty hardware if your department is willing to buy the replacement parts.¬† When IT determines that it is no longer financially or technically feasible to continue to support an older model, that model will be dropped from support and will no longer be fixed or serviced.

NOTE: Before any technology purchases, please be aware that IT will only support certain models of computers. For more information, see IT’s Computer Standardization policy.

Supported Windows PCs are listed more or less chronologically by date of release with the most current listed last.

Windows 10 desktops

Dell

  • OptiPlex 3040
  • OptiPlex 3050
  • OptiPlex 3060
  • OptiPlex 3070
  • OptiPlex 3080
  • Optiplex 3090
  • Optiplex 3000

HP

  • EliteDesk 705 G1
  • EliteDesk 705 G2
  • EliteDesk 705 G3
  • EliteDesk 705 G4
  • EliteDesk 800 G5
  • EliteDesk 800 G6
  • EliteDesk 805 G6

Windows 10 laptops

Dell

  • Latitude 3580
  • Latitude 3590
  • Latitude 3500
  • Latitude 5310
  • Latitude 3510
  • Latitude 5320
  • Latitude 5330
  • Latitude 3520
  • Latitude 3530

HP

  • ProBook 655 G1
  • ProBook 655 G2
  • ProBook 655 G3
  • ProBook 655 G4
  • ProBook 650 G3
  • ProBook 650 G4
  • ProBook 650 G5
  • ProBook 650 G8

 

Mac desktops

  • iMac 2017 or later
  • iMac Pro 2017 or later
  • Mac Mini 2018 or later
  • Mac Pro 2019 or later
  • Mac Studio 2022

Mac laptops

  • MacBook 2017 or later
  • MacBook Air 2018 or later
  • MacBook Pro 2017 or later

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Mac OS versions

Ventura is the latest version of Mac OS. Monterey was the previous version. Apple does not support running Ventura on any systems made before 2017. Do not attempt to update your Mac to the latest version if it is unsupported. The following are the only Mac systems that support Ventura:

  • MacBook 2017 or later
  • MacBook Air 2018 or later
  • MacBook Pro 2017 or later
  • Mac Mini 2018 or later
  • iMac 2017 or later
  • iMac Pro 2017 or later
  • Mac Pro 2019 or later
  • Mac Studio 2022

If your Mac is not one of these listed above, it will need to continue running Monterey or an earlier version. We do not support any Mac OS version earlier than Big Sur (11.7.1). For a complete listing of systems compatible with Ventura, click here.